您的位置:首页 > 其它

hdoj 1432 && poj 2606 Lining Up (多点共线)

2016-04-12 16:37 295 查看


Lining Up

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1326 Accepted Submission(s): 376



Problem Description

``How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points
were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?

Your program has to be efficient!

Input

The input consists of multiple test cases, and each case begins with a single positive integer on a line by itself indicating the number of points, followed by N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended
by a new-line character. No pair will occur twice in one test case.

Output

For each test case, the output consists of one integer representing the largest number of points that all lie on one line, one line per case.

Sample Input

5
1 1
2 2
3 3
9 10
10 11


Sample Output

3求最多共线的点数:任意两点的斜率相等,最好用移项相乘,(相除的变形),也别直接相除(容易引起小数点的误差)代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
struct Node
{
int x;
int y;
}a[1100];
int main()
{
int n,ans,max;
while(~scanf("%d",&n))
{
for(int i=0;i<n;i++)
{
scanf("%d%d",&a[i].x,&a[i].y);
}
max=0;
for(int i=0;i<n;i++)
{
for(int j=i+1;j<n;j++)
{
ans=0;
for(int k=j+1;k<n;k++)
{
if((a[j].x-a[i].x)*(a[k].y-a[j].y)-(a[k].x-a[j].x)*(a[j].y-a[i].y)==0)
ans++;
}
if(max<ans)
max=ans;
}
}
printf("%d\n",max+2);
}
return 0;
}


Rabbit hunt(相同题目)
Time
Limit:
1000MS
Memory Limit: 65536K
Total Submissions: 7915Accepted: 3942
DescriptionA good hunter kills two rabbits with one shot. Of course, it can be easily done since for any two points we can always draw a line containing the both. But killing three or more rabbits in one shot is much more difficult task. To be the best hunter in the world one should be able to kill the maximal possible number of rabbits. Assume that rabbit is a point on the plane with integer x and y coordinates. Having a set of rabbits you are to find the largest number K of rabbits that can be killed with single shot, i.e. maximum number of points lying exactly on the same line. No two rabbits sit at one point.InputAn input contains an integer N (2<=N<=200) specifying the number of rabbits. Each of the next N lines in the input contains the x coordinate and the y coordinate (in this order) separated by a space (-1000<=x,y<=1000).OutputThe output contains the maximal number K of rabbits situated in one line.Sample Input6
7 122
8 139
9 156
10 173
11 190
-100 1
Sample Output
5
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: