您的位置:首页 > 其它

HDU:1068 Girls and Boys(最大独立集)

2016-04-12 14:44 429 查看


Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9826    Accepted Submission(s): 4501


Problem Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying
the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students

the description of each student, in the following format

student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...

or

student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.

For each given data set, the program should write to standard output a line containing the result.

 

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

 

Sample Output

5
2

 

Source

Southeastern Europe 2000

 

Recommend

JGShining

 

题意:一些人有暧昧关系,求一个最大的集合,使该集合内的人没有暧昧关系。

解题思路:求最大独立集。最大独立集=元素个数-最大匹配数(最大独立集解释:如1、2有暧昧,3、4有暧昧,5、6有暧昧,7号没有,那么最大独立集就从1、2中取一个人放入该集合+从3、4中取一个人放入该集合+从5、6中取一个人放入该集合+7号)。

该题目0和1匹配与1和0配对重复,所以真正的最大匹配数=求出的最大匹配数/2(可自己举个例子画画图就理解了)。

#include <stdio.h>
#include <string.h>
int map[500][500];
int used[500];
int link[500];
int n;
bool erfen(int p)
{
for(int i=0;i<n;i++)
{
if(!used[i]&&map[p][i])
{
used[i]=1;
if(link[i]==-1||erfen(link[i]))
{
link[i]=p;
return 1;
}
}
}
return 0;
}
int main()
{
while(scanf("%d",&n)!=EOF)
{
memset(map,0,sizeof(map));
memset(link,-1,sizeof(link));
for(int i=0;i<n;i++)//必须用for循环,while不行,不知道为啥
{
int u,k;
scanf("%d: (%d)",&u,&k);
while(k--)
{
int v;
scanf("%d",&v);
map[u][v]=1;
}
}
int cnt=0;
for(int i=0;i<n;i++)
{
memset(used,0,sizeof(used));
if(erfen(i))
{
cnt++;
}
}
printf("%d\n",n-cnt/2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  二分图