您的位置:首页 > 其它

POJ 1012(Joseph)

2016-04-10 17:34 375 查看
Description

The Joseph’s problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, …, n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

3

4

0

Sample Output

5

30

(只适用于从1开始编号)

Joseph环问题当然要用Joseph环神奇的走步方式了。

ans[i]=(ans[i-1]+m-1)%(2*k-i+1);

ans[i]:第i次清的人

m:一次走的步数

k:好人的个数

2*k:总人数

i:第i次清人

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

int ans[15],data[15];

void init ()//愉快地打表
{
for (int k=1;k<14;k++)
{
int m=1;
memset(ans,0,sizeof(ans));
for (int i=1;i<=k;i++)//总共杀k个就停了
{
ans[i]=(ans[i-1]+m-1)%(2*k-i+1);//神奇的走步方式,要背下来
if (ans[i]<k)
{
i=0;
m++;
}
}
data[k]=m;
}
}

int main ()
{
int k;
init ();
while (scanf("%d",&k) , k)
printf("%d\n",data[k]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: