您的位置:首页 > 其它

FOJ Common Tangents

2016-04-10 09:48 218 查看
Problem Description

Two different circles can have at most four common tangents.

The picture below is an illustration of two circles with four common tangents.

Now given the center and radius of two circles, your job is to find how many common tangents between them.

Input

The first line contains an integer T, meaning the number of the cases (1 <= T <= 50.).

For each test case, there is one line contains six integers x1 (−100 ≤ x1 ≤ 100), y1 (−100 ≤ y1 ≤ 100), r1 (0 < r1 ≤ 200), x2 (−100 ≤ x2 ≤ 100), y2 (−100 ≤ y2 ≤ 100), r2 (0 < r2 ≤ 200). Here (x1, y1) and (x2, y2) are the coordinates of the center of the first
circle and second circle respectively, r1 is the radius of the first circle and r2 is the radius of the second circle.

Output

For each test case, output the corresponding answer in one line.

If there is infinite number of tangents between the two circles then output -1.

Sample Input

3

10 10 5 20 20 5

10 10 10 20 20 10

10 10 5 20 10 5 Sample Output

4

2

3

这一题由于是精度原因,建议用距离平方来表示,另外,是内切时,判断一下两圆是重合的情况,输出-1

AC代码:

# include <cstdio>
using namespace std;
int dis(int , int , int , int);
int main(){
int t, x1, x2, y1, y2, r1, r2, i, j, k, distance;
scanf("%d", &t);
for(i=1; i<=t; i++){
scanf("%d%d%d%d%d%d", &x1, &y1, &r1, &x2, &y2, &r2);
distance=dis(x1, y1, x2, y2);
if(distance>(r1+r2)*(r1+r2)){
printf("%d\n", 4);
continue;
}
if(distance==(r1+r2)*(r1+r2)){
printf("%d\n", 3);
continue;
}
if(distance>(r1-r2)*(r1-r2)&&distance<(r1+r2)*(r1+r2)){
printf("%d\n", 2);
continue;
}
if(distance==(r1-r2)*(r1-r2)){
if(distance==0){
printf("%d\n", -1);
continue;
}
printf("%d\n", 1);
continue;
}
printf("%d\n", 0);
}
return 0;
}
int dis(int x1, int y1, int x2, int y2){
return (x1-x2)*(x1-x2)+(y1-y2)*(y1-y2);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: