您的位置:首页 > 其它

HDOJ 2058 The sum problem

2016-04-09 19:28 218 查看
Problem Description

Given a sequence 1,2,3,……N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.

Input

Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

Output

For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

Sample Input

20 10

50 30

0 0

Sample Output

[1,4]

[10,10]

[4,8]

[6,9]

[9,11]

[30,30]

题意:对于1~n的序列,搜寻其中x~y序列,是它的值等于m,并按格式输出,这个序列。

肯定是要同二维for循环遍历,但是 1 <= N, M <= 1000000000必须要超时。

所以,这里有一个巧:对一个序列a1,a2,a3~an求和即n*(an+a1)/2=sum,,—>x*(x+1)/2=m;所以,x近似小于等于sqrt(2.0*m),在1~x之间,找到序列开始的前一个数。

接下来an=a1+n-1,则n*(an+a1)/2=n*(a1+n-1+a1)/2=sum—>2*n*a1=2*sum-n*n+1,a1就是序列的第一个数;

接下来在代码上有注释咯

import java.util.Scanner;

public class Main {
public static void main(String[] args) {
Scanner sc=new Scanner(System.in);
while(sc.hasNext()){
int n=sc.nextInt();
int m=sc.nextInt();
if(n==0&&m==0){
break;
}
int x=(int)Math.sqrt(2.0*m);
for(int i=x;i>0;i--){//i为符合序列的长度
int s=(2*m+i-i*i)/2;

if(s%i==0){//判断是否满足序列第一个数是否是整数的条件
int a=s/i;//求出第一个数
if(a+i-1>m){//判断最后一个数是否越界
break;
}
//                  System.out.println("s="+s+" a="+a+" i="+i);
System.out.printf("[%d,%d]",a,a+i-1);
System.out.println();
}
}
System.out.println();
}
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: