您的位置:首页 > 其它

hdu1390Binary Numbers

2016-04-09 17:14 253 查看
Problem Description

Given a positive integer n, find the positions of all 1’s in its binary representation. The position of the least significant bit is 0.

Example

The positions of 1’s in the binary representation of 13 are 0, 2, 3.

Task

Write a program which for each data set:

reads a positive integer n,

computes the positions of 1’s in the binary representation of n,

writes the result.

Input

The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

Output

The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1’s in the binary representation of the i-th input number.

Sample Input

1

13

Sample Output

0 2 3

分析:题目意思就是把数化为2进制,输出位数为1的位置。看了下数据,果断打表了!

#include<iostream>
#include<cstring>
#include<algorithm>
#include<string>
using namespace std;
int a[]={1,2,4,8,16,32,64,128,256,512,1024,2048,4096,8192,16384,32768,65536 ,131072,262144,524288};
int b[50],t,n;
int main()
{
cin>>t;
while(t--)
{
cin>>n;
int rel=0;
for(int i=19;i>=0;i--)
{
if(n>=a[i])
{
n-=a[i];
b[rel++]=i;
}
}
for(int i=rel-1;i>=0;i--)
{
cout<<b[i];
i==0?cout<<endl:cout<<" ";
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: