您的位置:首页 > 其它

1012. The Best Rank

2016-04-09 15:58 375 查看
思路:模拟题  先输入所有数据存入列表中,然后对每个id先查找其对应的三门课的成绩以及平均成绩,然后再统计比这四个数据大的 个数,最后根据题意判断哪个排名优先输出哪个?

练习:数组 表达式

题目表述:

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing
on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:
StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91


Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student
ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".
Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output
1 C
1 M
1 E
1 A
3 A
N/A

参考代码:

#include <iostream>
#include <string>
#include <vector>
using namespace std;
struct sStu
{
string id;
int C;
int M;
int E;
int A;
};
vector<sStu> stuList;
int main()
{
int N,M;
while(cin>>N>>M)
{
int i;
for(i=0;i<N;i++)
{
struct sStu stu;
cin>>stu.id>>stu.C>>stu.M>>stu.E;
stu.A=(stu.C+stu.M+stu.E)/3;
stuList.push_back(stu);
}
for(i=0;i<M;i++)
{
string id;
cin>>id;
vector<sStu>::iterator it;
for(it=stuList.begin();it!=stuList.end();it++)
if (it->id==id)
break;
if(it==stuList.end())
{
cout<<"N/A"<<endl;
continue;
}
int cc=0,cm=0,ce=0,ca=0;
for(vector<sStu>::iterator it2=stuList.begin();it2!=stuList.end();it2++)
{
if(it2->C>it->C) cc++;
if(it2->M>it->M) cm++;
if(it2->E>it->E) ce++;
if(it2->A>it->A) ca++;
}
int m=cc;
if(m>cm) m=cm;
if(m>ce) m=ce;
if(m>ca) m=ca;
if(m==ca)
cout<<m+1<<" A"<<endl;
else if(m==cc)
cout<<m+1<<" C"<<endl;
else if(m==cm)
cout<<m+1<<" M"<<endl;
else if(m==ce)
cout<<m+1<<" E"<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: