您的位置:首页 > 其它

DFS模板题---Lake Counting

2016-04-09 14:01 375 查看
Lake Counting

Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u

Submit

Status

Practice

POJ 2386

Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

Lines 2..N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

Output

Line 1: The number of ponds in Farmer John’s field.

Sample Input

10 12



Sample Output

3

Hint

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

标准的DFS模板题目,代码如下:

#include <stdio.h>
#include <string.h>
#define lim 500
void dfs(int x, int y, int map[][lim], int vis[][lim]);
int main ()
{
int row, col;
while(scanf("%d%d", &row, &col)!=EOF)
{
if(row==0)
return 0;
int i, j, count=0;
char str[800];
int  map[500][500], vis[500][500];//定义两个数组
memset(str, 0, sizeof(str));
memset(map, 0, sizeof(map));
memset(vis, 0, sizeof(vis));
for(i=0;i<row;i++)//进行题目中的输入
{
scanf("%s", str);//输入方法
for(j=0;j<col;j++)
map[i+1][j+1]=str[j]-'.';//相当于外边加一层 * ,防止搜索时数组越界!!!
}
for(i=1;i<=row;i++)
for(j=1;j<=col;j++)
if(map[i][j]==41 && vis[i][j]==0)//搜索时遇到还未被访问的@则进行搜索
{
dfs(i, j, map, vis);
count++;
}
printf("%d\n", count);
}
return 0;
}

void dfs(int x, int y, int map[][lim], int vis[][lim])
{
if(map[x][y]==0||vis[x][y]==1)
return;
vis[x][y]=1;
dfs(x, y-1, map, vis );//上
dfs(x, y+1, map, vis );//下
dfs(x-1, y , map, vis);//左
dfs(x+1, y, map, vis);//右
dfs(x-1, y-1, map, vis);//左上
dfs(x-1, y+1, map, vis );//左下
dfs(x+1, y-1, map, vis );//右上
dfs(x+1, y+1, map, vis );//右下
}


仅代表个人观点,欢迎交流探讨,勿喷~~~



PhotoBy:WLOP

http://weibo.com/wlop
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: