您的位置:首页 > 其它

HDOJ 1611 The Suspects 含翻译

2016-04-09 11:17 260 查看
The Suspects

Time Limit: 1000MSMemory Limit: 20000K
Total Submissions: 30754Accepted: 14952
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1

Source

Asia Kaohsiung 2003

中文版

严重急性呼吸系统综合症( SARS), 一种原因不明的非典型性肺炎,从2003年3月中旬开始被认为是全球威胁。为了减少传播给别人的机会, 最好的策略是隔离可能的患者。
在Not-Spreading-Your-Sickness大学( NSYSU), 有许多学生团体。同一组的学生经常彼此相通,一个学生可以同时加入几个小组。为了防止非典的传播,NSYSU收集了所有学生团体的成员名单。他们的标准操作程序(SOP)如下:
一旦一组中有一个可能的患者, 组内的所有成员就都是可能的患者。
然而,他们发现当一个学生被确认为可能的患者后不容易识别所有可能的患者。你的工作是编写一个程序, 发现所有可能的患者。

Input

输入文件包含多组数据。
对于每组测试数据:
第一行为两个整数n和m, 其中n是学生的数量, m是团体的数量。0 < n <= 30000,0 <= m <= 500。
每个学生编号是一个0到n-1之间的整数,一开始只有0号学生被视为可能的患者。
紧随其后的是团体的成员列表,每组一行。
每一行有一个整数k,代表成员数量。之后,有k个整数代表这个群体的学生。一行中的所有整数由至少一个空格隔开。
n = m = 0表示输入结束,不需要处理。

Output

对于每组测试数据, 输出一行可能的患者。

参考代码:

/*=============================AC情况===============================*/
/*题目网址:  http://poj.org/problem?id=1611 */
/*时间:2016年4月9日11:17:17 */
/*心得: 简单的并查集问题 */

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define G 53142

int pre[G];
int rank[G];

void init(int x) {
for(int j=0; j<x; j++) {
pre[j]=j;
rank[j]=1;
}
}

int find(int x) {
return x==pre[x]? x:find(pre[x]);
}

void join(int x,int y) {
int fx=find(x);
int fy=find(y);
if(fx==fy)
return ;
else {
pre[fy]=fx;
rank[fx]+=rank[fy];
}
}

int main() {
int n,m;
int q=0;
while(scanf("%d%d",&n,&m)&&(n||m)) {
init(n);
//q++;
while(m--) {
int k,ren0,ren;
scanf("%d%d",&k,&ren0);
for(int j=1; j<k; j++) {
scanf("%d",&ren);
join(ren0,ren);
//	printf("%d ",find(0));
}
}
int ans=rank[find(0)];
printf("%d\n",ans);
}
return 0;
}

/*********************************测试数据*********************************

**************************************************************************/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: