您的位置:首页 > 其它

♥POJ 1703-Find them, Catch them【并查集】

2016-04-09 11:07 375 查看
Find them, Catch them

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 39648Accepted: 12190
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given
two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]

where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output
Not sure yet.
In different gangs.
In the same gang.

Source

POJ Monthly--2004.07.18

解题思路:

a代表询问,d代表他们两个在不同的阵营,问他们之间的关系,主要是他和父节点之间的关系,(vi[a]+vi[b])%2,用它来处理之间的关系。

<pre name="code" class="cpp">#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int fa[120000];
int vi[120000];
int father(int x)
{
int t;
if(fa[x]==x)
{
return fa[x];
}
t=fa[x];
fa[x]=father(fa[x]);
vi[x]=(vi[t]+vi[x])%2;//这里的vi【x】只可能是0,因为是新加进来的点 保持和父节点一致
return fa[x];
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int i,j;
int n,m;
scanf("%d%d",&n,&m);
for(i=0;i<=n;i++)
{
fa[i]=i;
vi[i]=0;
}
if(n==2)
{
vi[2]=1;
fa[2]=1;
}
while(m--)
{
getchar();
char s;
int a,b;
scanf("%c %d %d",&s,&a,&b);
int ra,rb;
ra=father(a);
rb=father(b);
if(s=='A')
{
if(ra==rb)
{
if(vi[a]==vi[b])printf("In the same gang.\n");
else printf("In different gangs.\n");
}
else printf("Not sure yet.\n");
}
else
{
if(ra<rb)
{
fa[rb]=ra;//小点当父节点
vi[rb]=!((vi[a]+vi[b])%2);//再更新父节点保持他们两个不是统一阵营中的
}
else
{
fa[ra]=rb;
vi[ra]=!((vi[a]+vi[b])%2);
}
}
}
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: