您的位置:首页 > 其它

题目1098:字母统计

2016-04-09 09:23 387 查看
题目描述:

输入一行字符串,计算其中A-Z大写字母出现的次数
输入:

案例可能有多组,每个案例输入为一行字符串。
输出:

对每个案例按A-Z的顺序输出其中大写字母出现的次数。
样例输入:
DFJEIWFNQLEF0395823048+_+JDLSFJDLSJFKK

样例输出:
A:0
B:0
C:0
D:3
E:2
F:5
G:0
H:0
I:1
J:4
K:2
L:3
M:0
N:1
O:0
P:0
Q:1
R:0
S:2
T:0
U:0
V:0
W:1
X:0
Y:0
Z:0

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std;

const int maxn=26;
const int maxl=1000;
int t[maxn];
char s[maxl];
int main()
{
while(scanf("%s",s)!=EOF)
{
memset(t,0,sizeof(t));
for(int i=0;i<strlen(s);i++)
if((s[i]>='A')&&(s[i]<='Z'))
t[s[i]-'A']++;
for(int i=0;i<maxn;i++)
printf("%c:%d\n",'A'+i,t[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: