您的位置:首页 > 其它

POJ2777_Count Color

2016-04-08 17:10 232 查看
Count Color
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 41391 Accepted: 12511
二进制存储颜色,lazy思想;DescriptionChosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segmentwith only one color. We can do following two operations on the board: 1. "C A B C" Color the board from segment A to segment B with color C. 2. "P A B" Output the number of different colors painted between segment A and segment B (including). In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At thebeginning, the board was painted in color 1. Now the rest of problem is left to your. InputFirst line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operationdefined previously.OutputOuput results of the output operation in order, each line contains a number.Sample Input
2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2
Sample Output
2
1
SourcePOJ Monthly--2006.03.26,dodo
#include<cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <queue>
#include <stack>
#include <set>
#include <queue>
#include <map>
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
using namespace std;
const int N=1e5+10;
int col[N<<2];
int Add[N<<2];
void build()
{
Add[1]=1;
col[1]=1;
}
void pushup(int rt)
{
col[rt]=col[rt<<1]|col[rt<<1|1];
}
void pushdown(int rt)
{
if(Add[rt]!=-1)
{
Add[rt<<1]=Add[rt<<1|1]=Add[rt];
col[rt<<1]=col[rt<<1|1]=Add[rt];
Add[rt]=-1;
}
}
void update(int L,int R,int c,int l,int r,int rt)
{
if(L<=l&&R>=r)
{
Add[rt]=1<<(c-1);
col[rt]=1<<(c-1);
return;
}
if(L>r||R<l)
return;
pushdown(rt);
int mid=(l+r)>>1;
update(L,R,c,lson);
update(L,R,c,rson);
pushup(rt);
}
int Query(int L,int R,int l,int r,int rt)
{
if(L<=l&&R>=r)
{
return col[rt];
}
if(L>r||R<l)
return 0;
pushdown(rt);
int mid=(l+r)>>1;
return Query(L,R,lson)|Query(L,R,rson);
}
int main()
{
int l,t,o;
int a,b,c;
char s[2];
scanf("%d%d%d",&l,&t,&o);
build();
while(o--)
{
scanf("%s",s);
if(s[0]=='C')
{
scanf("%d%d%d",&a,&b,&c);
if(a>b)
swap(a,b);
update(a,b,c,1,l,1);
}
else
{
scanf("%d%d",&a,&b);
if(a>b)
swap(a,b);
int tmp=Query(a,b,1,l,1);
int ans=0;
while(tmp)
{
if(tmp&1)
ans++;
tmp>>=1;
}
printf("%d\n",ans);
}
}
return 0;
}

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: