您的位置:首页 > 其它

POJ 2230 Watchcow【有向图的欧拉回路+DFS遍历】

2016-04-08 12:47 344 查看
Watchcow

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 6869 Accepted: 2998 Special Judge
Description

Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done. 

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see.
But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice. 

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.
Input

* Line 1: Two integers, N and M. 

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.
Output

* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.
Sample Input
4 5
1 2
1 4
2 3
2 4
3 4

Sample Output
1
2
3
4
2
1
4
3
2
4
1

Hint

OUTPUT DETAILS: 

Bessie starts at 1 (barn), goes to 2, then 3, etc...
Source

USACO 2005 January Silver

题目大意:给出一个n个点,m条边组成的欧拉回路图,每条边都是无向图,问每条边都走两次(且方向相反),输出顶点。

思路:

把每个无向图都改成有向图,每条有向边都存在vetor中(这个题卡内存卡的还是比较严的),然后从起点1开始遍历各个点即可。

AC代码:
#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
struct path
{
int v;int flag;
};
vector<path>mp[10005];
void dfs(int x)
{
//printf("%d\n",x);
for(int i=0;i<mp[x].size();i++)
{
if(mp[x][i].flag==0)
{
mp[x][i].flag=1;
dfs(mp[x][i].v);
}
}
printf("%d\n",x);
}
int main()
{
int n,m;
while(~scanf("%d%d",&n,&m))
{
for(int i=0;i<=n;i++)
{
mp[i].clear();
}
for(int i=0;i<m;i++)
{
int x,y;
scanf("%d%d",&x,&y);
path now;
now.v=y;
now.flag=0;
mp[x].push_back(now);
now.v=x;
mp[y].push_back(now);
}
dfs(1);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ 2230