您的位置:首页 > 其它

吃土豆

2016-04-08 10:16 399 查看
描述
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans
and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and
x+1.



Now, how much qualities can you eat and then get ?

输入There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean
isn't beyond 1000, and 1<=M,N<=500.

输出For each case, you just output the MAX qualities you can eat and then get.
样例输入
4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6


样例输出

242

考虑对于某行某列元素,row[i][j]表示加上位置为i,j的土豆的质量的i行j列最大的和

列的最大值:row[i][j]=max(row[i][j-2]+row[i][j-3])+val

看图说话:



假设红色的格子为i行j列,那么它的前面有两种选择方案:

1、选择蓝色格子

2、选择黄色格子

那么该行最大的和是什么呢?

由于n列、n-1列具有状态无关性(n-1列的状态影响不了n列的状态),很显然等于max(row[i]
,row[i][n-1])

 

同理对于dp[i] (i行的最大值)

dp[i]=max(dp[i-2],dp[i-3])+max_row[i]

看图说话:



max土豆质量=max(dp[m],dp[m-1])

为了方便计算,我的代码把n,m扩大了2

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int e[505][505],dp[505];
int n,m;
int main(){
while(scanf("%d%d",&m,&n)!=EOF){
memset(e,0,sizeof(dp));
memset(dp,0,sizeof(dp));
int i,j,map;
for(i=3;i<m+3;++i){
for(j=3;j<n+3;++j){
scanf("%d",&map);
e[i][j]=max(e[i][j-2],e[i][j-3])+map;
}
}
for(i=3;i<m+3;++i){
dp[i]=max(dp[i-2],dp[i-3])+max(e[i][n+1],e[i][n+2]);
}
printf("%d\n",max(dp[m+1],dp[m+2]));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dp