您的位置:首页 > Web前端

HDU - 5479 Scaena Felix (栈模拟)水

2016-04-07 22:13 453 查看
HDU
- 5479

Scaena Felix

Time Limit: 1000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u
Submit Status

Description

Given a parentheses sequence consist of '(' and ')', a modify can filp a parentheses, changing '(' to ')' or ')' to '('. 

If we want every not empty <b>substring</b> of this parentheses sequence not to be "paren-matching", how many times at least to modify this parentheses sequence? 

For example, "()","(())","()()" are "paren-matching" strings, but "((", ")(", "((()" are not.
 

Input

The first line of the input is a integer 

,
meaning that there are 

 test
cases. 

Every test cases contains a parentheses sequence 

 only
consists of '(' and ')'. 






















.
 

Output

For every test case output the least number of modification.
 

Sample Input

3
()
((((
(())

 

Sample Output

1
0
2

 

Source

BestCoder Round #57 (div.2)

//题意:

给你一串字符串,问有几对括号

直接栈模拟就行了

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#define INF 0x3f3f3f3f
#define ull unsigned lonb long
#define ll long long
#define IN __int64
#define N 1010
#define M 1000000007
using namespace std;
stack<char>ss;
char s
;
int main()
{
int t,i,j;
scanf("%d",&t);
while(t--)
{
scanf("%s",s);
int len=strlen(s);
int l=0,r=0;
for(i=0;i<len;i++)
{
if(s[i]=='(')
{
l++;
ss.push(s[i]);
}
else
{
if(l)
{
r++;l--;
ss.pop();
}
}
}
printf("%d\n",r);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: