您的位置:首页 > 其它

HDU 1342 Lotto

2016-04-07 21:11 302 查看


Problem Description

In a Lotto I have ever played, one has to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn't increase your chance of winning - is to select a subset S containing k (k>6) of these 49 numbers, and then play several
games with choosing numbers only from S. For example, for k=8 and S = {1,2,3,5,8,13,21,34} there are 28 possible games: [1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34], [1,2,3,5,13,21], ... [3,5,8,13,21,34]. 

Your job is to write a program that reads in the number k and the set S and then prints all possible games choosing numbers only from S.


Input

The input file will contain one or more test cases. Each test case consists of one line containing several integers separated from each other by spaces. The first integer on the line will be the number k (6 < k < 13). Then k integers, specifying the set S,
will follow in ascending order. Input will be terminated by a value of zero (0) for k. 


Output

For each test case, print all possible games, each game on one line. The numbers of each game have to be sorted in ascending order and separated from each other by exactly one space. The games themselves have to be sorted lexicographically, that means sorted
by the lowest number first, then by the second lowest and so on, as demonstrated in the sample output below. The test cases have to be separated from each other by exactly one blank line. Do not put a blank line after the last test case. 


Sample Input

7 1 2 3 4 5 6 7
8 1 2 3 5 8 13 21 34
0



Sample Output

1 2 3 4 5 6
1 2 3 4 5 7
1 2 3 4 6 7
1 2 3 5 6 7
1 2 4 5 6 7
1 3 4 5 6 7
2 3 4 5 6 7

1 2 3 5 8 13
1 2 3 5 8 21
1 2 3 5 8 34
1 2 3 5 13 21
1 2 3 5 13 34
1 2 3 5 21 34
1 2 3 8 13 21
1 2 3 8 13 34
1 2 3 8 21 34
1 2 3 13 21 34
1 2 5 8 13 21
1 2 5 8 13 34
1 2 5 8 21 34
1 2 5 13 21 34
1 2 8 13 21 34
1 3 5 8 13 21
1 3 5 8 13 34
1 3 5 8 21 34
1 3 5 13 21 34
1 3 8 13 21 34
1 5 8 13 21 34
2 3 5 8 13 21
2 3 5 8 13 34
2 3 5 8 21 34
2 3 5 13 21 34
2 3 8 13 21 34
2 5 8 13 21 34
3 5 8 13 21 34



Source

University of Ulm Local Contest 1996

题意:以升序的形式给定k个数,输出从中挑选6个数满足升序的每一种情况。

思路:dfs时设置两个参数,第一个保存当前搜索的位置,第二个保存个数。

#include <iostream>
#include <string.h>
using namespace std;
int n,a[15],b[15],v[15];
void dfs(int d,int c)
{
int i;
if(c==6)
{
for(i=0; i<5; i++)
cout<<b[i]<<" ";
cout<<b[5]<<endl;;
return ;
}
for (i=d; i<n; i++)
{
if(!v[i])
{
v[i]=1;
b[c]=a[i];
dfs(i+1,c+1);
v[i]=0;
}
}
}
int main()
{
int i,j=0;
while(cin>>n&&n!=0)
{
for(i=0; i<n; i++)
cin>>a[i];
if(j)
cout<<endl;
else j=1;
memset(v,0,sizeof(v));
dfs(0,0);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: