您的位置:首页 > 其它

杭电1009

2016-04-07 13:02 274 查看

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 62414    Accepted Submission(s): 21050


[align=left]Problem Description[/align]
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 

[align=left]Input[/align]
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case
is followed by two -1's. All integers are not greater than 1000.

 

[align=left]Output[/align]
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 

[align=left]Sample Input[/align]

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

 

[align=left]Sample Output[/align]

13.333
31.500

#include <stdio.h>

typedef struct node

{

    int j;

    int f;

    double radio;

}Node;

int main(){

    Node list[1005];

    int cat,n;

    while(scanf("%d %d",&cat,&n)!=EOF && cat != -1 && n != -1){

        int i = 0;

        for(i = 0; i < n; i++){

            scanf("%d %d",&list[i].j,&list[i].f);

            list[i].radio = (double)list[i].j/list[i].f;

            if(i){

                Node key = list[i];

                //printf("key is %d %d %lf\n",key.j,key.f,key.radio);

                int j = i - 1;

                while(j >=0 && key.radio > list[j].radio){

                    list[j + 1] = list[j];

                    j--;

                }

                list[j + 1] = key;

            }

        }

       /* for(i = 0; i < n; i++){

            printf("%lf\n",list[i].radio);

        }*/

        double sum;

        for(i = 0, sum = 0; cat && i < n; i++){

            if(list[i].f > cat){

                sum += cat * list[i].radio;

                cat = 0;

            }else{

                cat -= list[i].f;

                sum += list[i].j;

            }

        }

        printf("%.3lf\n",sum );

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电