您的位置:首页 > 其它

poj 3041 Asteroids

2016-04-07 09:30 211 查看
/*

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500)

. The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find
the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input
* Line 1: Two integers N and K, separated by a single space.

* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
Output
* Line 1: The integer representing the minimum number of times Bessie must shoot.
Sample Input
3 4
1 1
1 3
2 2
3 2

Sample Output
2


*/

给一个N*N的矩阵,有些格子有障碍,要求我们消除这些障碍,问每次消除一行或一列的障碍,
最少要几次。这里将每行x看成一个X结点,每列Y看成一个Y结点,障碍的坐标x,y看成X到Y的
一条边,构建出图后,就变成了找最少的点,使得这些点与所有的边相邻,即最小点覆盖问题。
/*
二部图的匹配问题,匈牙利算法
*/
#include <stdio.h>
int e[501][501];
int match[501];
int book[501];
int n,m;
int DFS(int u)
{
int i;
for(i=1;i<=n;i++)
{
if(book[i]==0 && e[u][i]==1)
{
book[i] = 1;
if(match[i]==0 || DFS(match[i]))
{
match[i] = u;
match[u] = i;
return 1;
}
}
}
return 0;
}
int main()
{
int i, j, t1, t2, sum = 0;
scanf("%d%d",&n,&m);
for(i=1;i<=m;i++)
{
scanf("%d%d",&t1,&t2);
e[t1][t2] = 1;
}
for(i=1;i<=n;i++)
{
match[i] = 0;
}
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
book[j] = 0;//清空上次搜索时的标记
}
if(DFS(i))
{
sum ++ ;//寻找增广路,找到,匹配数加 1
}
}
printf("%d\n",sum);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: