您的位置:首页 > 其它

♥HDOJ 2407-Knots【大爷的规律题】

2016-04-06 21:49 288 查看

Knots

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 259 Accepted Submission(s): 180

[align=left]Problem Description[/align]
An even number N of strands are stuck through a wall. On one side of the wall, a girl ties N/2 knots between disjoint pairs of strands. On the other side of the wall, the girl's groom-to-be also ties N/2 knots between disjoint pairs
of strands. You are to find the probability that the knotted strands form one big loop (in which case the couple will be allowed to marry).

For example, suppose that N = 4 and you number the strands 1, 2, 3, 4. Also suppose that the girl has created the following pairs of strands by tying knots: {(1, 4), (2,3)}. Then the groom-to-be has two choices for tying the knots on his side: {(1,2), {3,4)}
or {(1,3), (2,4)}.

[align=left]Input[/align]
The input file consists of one or more lines. Each line of the input file contains a positive even integer, less than or equal to 100. This integer represents the number of strands in the wall.

[align=left]Output[/align]
For each line of input, the program will produce exactly one line of output: the probability that the knotted strands form one big loop, given the number of strands on the corresponding line of input. Print the probability to 5 decimal
places.

[align=left]Sample Input[/align]

4
20


[align=left]Sample Output[/align]

0.66667
0.28377


#include<string.h>
#include<stdio.h>
int main()
{
int n;
double num[100000];
memset(num,0,sizeof(num));
num[2]=1.0;
for(int i=4;i<110;i+=2)
{
num[i]=num[i-2]*((double)(i-2)/(i-1));
}
while(scanf("%d",&n)!=EOF)
{
printf("%.5lf\n",num
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: