您的位置:首页 > 产品设计 > UI/UE

杭电 3177 Crixalis's Equipment

2016-04-06 19:17 537 查看
http://acm.hdu.edu.cn/showproblem.php?

pid=3177


Crixalis's Equipment

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2562 Accepted Submission(s): 1056



[align=left]Problem Description[/align]


Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he's a guardian of Lich King now, he keeps the
living habit of a scorpion like living underground and digging holes.

Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it's just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis
has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely
Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.

[align=left]Input[/align]
The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of
equipment respectively. The next N lines contain N pairs of integers: Ai and Bi.

0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.

[align=left]Output[/align]
For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".

[align=left]Sample Input[/align]

2

20 3
10 20
3 10
1 7

10 2
1 10
2 11


[align=left]Sample Output[/align]

Yes
No


AC代码:

<span style="font-size:18px;">#include<iostream>
#include<cstdio>
#include<algorithm>

using namespace std;

struct Node
{
int a,b;
int c;
}s[1005];

bool cmp(Node a,Node b)
{
return a.c>b.c;
}

int main()
{
int T,V,N,i;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&V,&N);
for(i=0;i<N;i++)
{
scanf("%d%d",&s[i].a,&s[i].b);
s[i].c=s[i].b-s[i].a;
}

sort(s,s+N,cmp);

for(i=0;i<N;i++)
{
if(s[i].b>V)
{
printf("No\n");
break;
}
else
V=V-s[i].a;
}
if(i==N)
printf("Yes\n");
}
return 0;
}
</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: