您的位置:首页 > 其它

Billboard

2016-04-06 18:49 253 查看
将h分割对其建树,树的大小siz=min(h,n)维护区间剩余最长的长度

http://acm.hdu.edu.cn/showproblem.php?pid=2795


Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 17454    Accepted Submission(s): 7365


Problem Description

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu,
and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

 

Input

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

 

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard,
output "-1" for this announcement.

 

Sample Input

3 5 5
2
4
3
3
3

 

Sample Output

1
2
1
3
-1

 
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <cmath>
#include <string>
#include <iostream>
#include <string>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define LL long long
const int SIZE=2e5+10;
using namespace std;
struct sge{
int len;
}a[SIZE<<2];
void pushup(int rt){
a[rt].len=max(a[rt<<1].len,a[rt<<1|1].len);
}
void build(int w,int l,int r,int rt){
if(l==r){
a[rt].len=w;
return;
}
int m=(l+r)>>1;
build(w,lson);
build(w,rson);
pushup(rt);
}
int query(int c,int l,int r,int rt){
if(l==r){
99ba
a[rt].len-=c;
return l;
}
int m=(l+r)>>1;
int ls=a[rt<<1].len;
int ans;
if(ls>=c)ans=query(c,lson);
else ans=query(c,rson);
pushup(rt);
return ans;
}
int main()
{
int h,w,n,x;
while(scanf("%d%d%d",&h,&w,&n)!=EOF){
int siz=min(h,n);
build(w,1,siz,1);
for(int i=0;i<n;i++){
scanf("%d",&x);
if(a[1].len<x){
printf("-1\n");
continue;
}
printf("%d\n",query(x,1,siz,1));
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: