您的位置:首页 > 其它

hdu1856 More is better--并查集

2016-04-06 13:57 423 查看
原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1856
一:原题内容

[align=left]Problem Description[/align]
Mr Wang wants some boys to help him with a project. Because the project is rather complex,
the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are
still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

 

[align=left]Input[/align]
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends.
(A ≠ B, 1 ≤ A, B ≤ 10000000)
 

[align=left]Output[/align]
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

[align=left]Sample Input[/align]

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

 
[align=left]Sample Output[/align]

4
2

Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

 
二:分析理解

 题意:

王老师要找一些男生帮助他完成一项工程。要求最后挑选出的男生之间都是朋友关系,可以说直接的,也可以是间接地。问最多可以挑选出几个男生(最少挑一个)。 这是一个有关并查集的题目。只不过不是求有几个集合,而是求每个集合中元素的个数,进而求出个数的最大值。和求集合个数的方法差不多,只需要在合并两个集合时处理一下,让这两个集合的元素个数也合并一下就行了。接下来只需要找出最大值即可。要注意的一个地方就是:当n=0时,要输出1。

三:AC代码

#include<iostream>
#include<string.h>
#include<algorithm>
#define N 10000005
using namespace std;

int pre
;
int num
;
int m;
int a, b;
int ans;

int Find(int x)
{
if (pre[x] != x)
pre[x] = Find(pre[x]);
return pre[x];
}

void Union(int x, int y)
{
int x_root = Find(x);
int y_root = Find(y);

if (x_root != y_root)
{
pre[x_root] = y_root;
num[y_root] += num[x_root];
ans = max(ans, num[y_root]);
}
}

int main()
{
while (~scanf("%d", &m))
{
ans = 1;//包含了m=0时的情况
fill(num, num + N, 1);
for (int i = 1; i < N; i++)
pre[i] = i;

while (m--)
{
scanf("%d%d", &a, &b);
Union(a, b);
}

printf("%d\n", ans);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: