您的位置:首页 > 其它

zoj 1061 Web Navigation

2016-04-06 00:37 501 查看
Web NavigationTime Limit: 2 Seconds Memory Limit: 65536 KB
Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this.

The following commands need to be supported:

BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored.

FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored.

VISIT <url>: Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied.

QUIT: Quit the browser.

Assume that the browser initially loads the web page at the URL http://www.acm.org/
This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.

Output

For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

Sample Input

1

VISIT http://acm.ashland.edu/ VISIT http://acm.baylor.edu/acmicpc/ BACK
BACK
BACK
FORWARD
VISIT http://www.ibm.com/ BACK
BACK
FORWARD
FORWARD
FORWARD
QUIT

Sample Output
http://acm.ashland.edu/ http://acm.baylor.edu/acmicpc/ http://acm.ashland.edu/ http://www.acm.org/
Ignored http://acm.ashland.edu/ http://www.ibm.com/ http://acm.ashland.edu/ http://www.acm.org/ http://acm.ashland.edu/ http://www.ibm.com/
Ignored

按照题目采用两个栈就可以。

c++中的stack没有clear函数,这里采用了重新构造一个,会造成内存泄露,但对此题没有影响

#include <iostream>
#include <cmath>
#include <cstdio>
#include <vector>
#include <list>
#include <string>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <set>
#include <stack>

using namespace std;

int main()
{
int n;
cin >> n;
cin.ignore();

while (n--)
{
string cmd;
cin.ignore();

stack<string> forward, back;
back.push("http://www.acm.org/");

while (cin >> cmd && cmd != "QUIT")
{
if (cmd == "VISIT")
{
string url;
cin >> url;
forward = stack<string>();
back.push(url);
cout << back.top() << endl;
}
else if (cmd == "BACK")
{
if (back.size() > 1)
{
forward.push(back.top());
back.pop();
cout << back.top() << endl;
}
else
cout << "Ignored" << endl;
}
else
{
if (!forward.empty())
{
back.push(forward.top());
forward.pop();
cout << back.top() << endl;
}
else
cout << "Ignored" << endl;
}
}
if (n > 0)
cout << endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: