您的位置:首页 > 其它

hdoj 3501

2016-04-05 18:52 323 查看
Calculation 2

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3295 Accepted Submission(s): 1360

Problem Description

Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.

Input

For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.

Output

For each test case, you should print the sum module 1000000007 in a line.

Sample Input

3

4

0

Sample Output

0

2

Author

GTmac

欧拉公式的引伸:小于或等于n的数中,与n互质的数的总和为:φ(x) * x / 2。(n>=1);

代码:

#include<cstdio>
#include<cstring>
#include<queue>
#include<vector>
#include<algorithm>
using namespace std;
#define LL long long
#define MOD 1000000007
LL euler(LL n)
{
LL i;
LL eu=n;
for(i=2;i*i<=n;i++)
{
if(n%i==0)
{
eu=eu*(i-1)/i;
while(n%i==0)
n/=i;
}
}
if(n>1)
eu=eu*(n-1)/n;
return eu;
}
int main()
{
LL t;
while (scanf("%lld",&t),t)
{
LL s=0;
s+=t*(t-1)/2-euler(t)*t/2;
printf("%lld\n",s%MOD);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: