您的位置:首页 > 其它

♥HDOJ 1443-Joseph【约瑟夫环+规律】

2016-04-05 16:27 281 查看

Joseph

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2247 Accepted Submission(s): 1366

[align=left]Problem Description[/align]
The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last
remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4,
6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

[align=left]Input[/align]
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

[align=left]Output[/align]
The output file will consist of separate lines containing m corresponding to k in the input file.

[align=left]Sample Input[/align]

3
4
0


[align=left]Sample Output[/align]

5
30


[align=left]Source[/align]
ACM暑期集训队练习赛(5)

解题思路:
保留前面的k个人,报数踢掉后面的人,如果要做到这样我们会注意到,只需要更新最开头的那个数,直到开头那个数大于k。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[1200],b[1200];
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
if(n==0)
break;
if(b
!=0)
{
printf("%d\n",b
);
continue;
}
int i,j;
int k=n;
n=n*2;
int m=1;
a[0]=0;
for(i=1;i<=k;i++)//1~k号是保留的    一直更新a【1】当他比k大时就是我们要找的结果
{
a[i]=(a[i-1]+m-1)%(n-i+1);
if(a[i]<k)
{
m++;
i=0;
}
}
b[k]=m;
printf("%d\n",b[k]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: