您的位置:首页 > 其它

1002. A+B for Polynomials (25)

2016-04-05 13:15 525 查看
This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2


//要考虑所有的情况,第一个多项式为零,和第二个多项式为零,以及两个想加为零的情况
#include<iostream>
#include<vector>
#include <iomanip>
using namespace std;
typedef struct plo
{
int expo;
float coef;
}plo;
int main()
{
vector<plo> vec1;
vector<plo>::iterator iter;
int expo,num1=0,num11=0,num2=0,flag=0,flag1=1;
float coef;
cin>>num1;
num11=num1;
while(num11>0)
{
plo plo1;
cin>>plo1.expo>>plo1.coef;
vec1.push_back(plo1);
num11--;
}
cin>>num2;
while(num2>0)
{
flag1=1;
flag=0;
cin>>expo>>coef;
if(num1==0)//如果第一个多项式为零,则将第二个多项式所有的都存入向量
{
plo plo1;
plo1.expo=expo;
plo1.coef=coef;
vec1.push_back(plo1);
}
else
{
for(int i=0;i<vec1.size();i++)//分三种情况,第一种就是第二个多项式中的一个项在第一个多项式中有相同的项
{
if((vec1[i]).expo==expo)
{
(vec1[i]).coef+=coef;
if(vec1[i].coef==0)//一定要考虑等于零的情况,如果等于零,则将该项删除
vec1.erase(vec1.begin()+i);
flag=1;//设置标志为1
}
}
for(int i=0;i<vec1.size();i++)//用索引,如果用迭代器则再插入元素后,迭代器失效,
{
if(flag==1)
{
break;
}
if((vec1[i]).expo<expo)//第二种情况,第二个多项式中的某一项在第一个多项式中没有,则直接将该项插入相应的位置
{
flag1=0;
plo plo1;
plo1.expo=expo;
plo1.coef=coef;
vec1.insert(vec1.begin()+i,plo1);
break;
}
}
if(flag1==1&&flag!=1)//第三种情况,第二个多项式中的某一项直接放在向量的最后面,如1 100 3.0,2 30 3.0 20 2.0
{
plo plo1;
plo1.expo=expo;
plo1.coef=coef;
vec1.push_back(plo1);
}
}
num2--;
}
cout<<vec1.size();//输出时候要注意最后面一个不要空格,当相加后的结果为0时,直接输出0即可
if(vec1.size()!=0)
{
cout<<' ';
}
for(iter=vec1.begin();iter!=vec1.end();iter++)
{
cout<<(*iter).expo<<" "<<fixed<<setprecision(1)<<(*iter).coef;
if(iter<vec1.end()-1)
cout<<" ";
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: