您的位置:首页 > 其它

HDOJ 5242 Game

2016-04-05 11:18 381 查看


Game

Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 584 Accepted Submission(s): 170



Problem Description

It is well known that Keima Katsuragi is The Capturing God because of his exceptional skills and experience in ''capturing'' virtual girls in gal games. He is able to playk games
simultaneously.

One day he gets a new gal game named ''XX island''. There are n scenes
in that game, and one scene will be transformed to different scenes by choosing different options while playing the game. All the scenes form a structure like a rooted tree such that the root is exactly the opening scene while leaves are all the ending scenes.
Each scene has a value , and we use wi as
the value of the i-th
scene. Once Katsuragi entering some new scene, he will get the value of that scene. However, even if Katsuragi enters some scenes for more than once, he will get wi for
only once.

For his outstanding ability in playing gal games, Katsuragi is able to play the game k times
simultaneously. Now you are asked to calculate the maximum total value he will get by playing that game for k times.

Input

The first line contains an integer T(T≤20),
denoting the number of test cases.

For each test case, the first line contains two numbers n,k(1≤k≤n≤100000),
denoting the total number of scenes and the maximum times for Katsuragi to play the game ''XX island''.

The second line contains n non-negative
numbers, separated by space. The i-th
number denotes the value of the i-th
scene. It is guaranteed that all the values are less than or equal to 231−1.

In the following n−1 lines,
each line contains two integers a,b(1≤a,b≤n),
implying we can transform from the a-th
scene to the b-th
scene.

We assume the first scene(i.e., the scene with index one) to be the opening scene(i.e., the root of the tree).

Output

For each test case, output ''Case #t:'' to represent the t-th
case, and then output the maximum total value Katsuragi will get.

Sample Input

2
5 2
4 3 2 1 1
1 2
1 5
2 3
2 4
5 3
4 3 2 1 1
1 2
1 5
2 3
2 4


Sample Output

Case #1: 10
Case #2: 11


Source

The 2015 ACM-ICPC China Shanghai Metropolitan
Programming Contest

/* ***********************************************
Author        :CKboss
Created Time  :2015年06月07日 星期日 16时39分51秒
File Name     :HDOJ5239.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

typedef long long int LL;

const int maxn=100100;

int n,m;

struct Edge
{
int to,next;
}edge[maxn*2];

int Adj[maxn],Size;

void init()
{
memset(Adj,-1,sizeof(Adj)); Size=0;
}

void Add_Edge(int u,int v)
{
edge[Size].next=Adj[u];
edge[Size].to=v;
Adj[u]=Size++;
}

LL val[maxn],sumv[maxn];
priority_queue<LL> q;

LL dfs(int u,int fa)
{
LL pos=0;
for(int i=Adj[u];~i;i=edge[i].next)
{
int v=edge[i].to;
if(v==fa) continue;
sumv[v]=dfs(v,u);
if(sumv[v]>sumv[pos]) pos=v;
}
for(int i=Adj[u];~i;i=edge[i].next)
{
int v=edge[i].to;
if(v==pos||v==fa) continue;
q.push(sumv[v]);
}
sumv[u]=val[u]+sumv[pos];
return sumv[u];
}

int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);

int T_T,cas=1;
scanf("%d",&T_T);
while(T_T--)
{
scanf("%d%d",&n,&m);
init();
for(int i=1;i<=n;i++)
{
scanf("%I64d",val+i);
}
for(int i=0,u,v;i<n-1;i++)
{
scanf("%d%d",&u,&v);
Add_Edge(u,v); Add_Edge(v,u);
}
while(!q.empty()) q.pop();
dfs(1,1);
q.push(sumv[1]);
LL ans=0;
while(!q.empty()&&m--)
{
ans += q.top();
q.pop();
}

printf("Case #%d: %I64d\n",cas++,ans);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: