您的位置:首页 > 其它

LA 3266&HDU 1052 Tian Ji -- The Horse Racing(田忌赛马,贪心)

2016-04-04 18:31 489 查看


Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 25009 Accepted Submission(s): 7289



Problem Description

Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from
the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you
think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's
horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find
the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too
advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers
on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0


Sample Output

200
0
0


Source

2004 Asia Regional Shanghai

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1052

思路:田忌赛马的故事大家都应该知道吧。先把田忌和齐王的马按速度从大到小排序,如果田忌最快的马比齐王最快的马还要快,就这两匹马比,赢一局,如果不行,就看最慢的马,如果田忌最慢的马比齐王最慢的马还快,就这两匹马比,赢一局,如果不行,就用用田忌最慢的马与齐王最快的马比,输一局。

AC代码:

#include<cstdio>
#include<algorithm>
using namespace std;
int cmp(int a,int b)
{
return a>b;
}
int main()
{
int a[1005],b[1005];
int n;
while(scanf("%d",&n),n)
{
for(int i=0; i<n; i++)
scanf("%d",&a[i]);
for(int i=0; i<n; i++)
scanf("%d",&b[i]);
sort(a,a+n,cmp);
sort(b,b+n,cmp);
int TFirst=0,QFirst=0;
int TEnd=n-1,QEnd=n-1;
int win=0;
while(n--)
{
if(a[TFirst]>b[QFirst])//田忌最快的马比齐王最快的快
{
TFirst++,QFirst++;
win++;
}
else if(a[TEnd]>b[QEnd])//田忌最慢的马比齐王最慢的快
{
TEnd--,QEnd--;
win++;
}
else if(a[TEnd]<b[QFirst])//用田忌最慢的马与齐王最快的马比
{
win--,TEnd--;
QFirst++;
}
}
printf("%d\n",win*200);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: