您的位置:首页 > 其它

poj 1852 ants

2016-04-04 17:43 323 查看
果然数组开小就会runtime error

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know
the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers
giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.
Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such
time.

Sample Input
2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output
4 8
38 207

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 1000000
int a[maxn+2];

int main()
{
int T;

scanf("%d",&T);
while(T--)
{
int max_t = 0;
int min_t = 0;
int n,l;

scanf("%d%d",&l,&n);
for(int i=0; i<n; i++)

scanf("%d",&a[i]);
for(int i=0; i<n; i++)
max_t = max(max_t,max(a[i],l-a[i]));
for(int i=0; i<n; i++)
min_t = max(min_t,min(a[i],l-a[i]));

printf("%d %d\n",min_t,max_t);
memset(a,0,sizeof(a));

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: