您的位置:首页 > 其它

ZOJ 3870 2015省赛的B 技巧题

2016-04-04 14:09 507 查看
B - Team Formation
Time Limit:3000MS     Memory Limit:131072KB     64bit IO Format:%lld
& %llu
Submit Status Practice ZOJ
3870

Description

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be A ⊕ B, where ⊕ means bitwise exclusive or. A team will play
well if and only if the skill level of the team is greater than the skill level of each team member (i.e. A ⊕ B > max{A, B}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ith integer denotes the skill level
of ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input

2
3
1 2 3
5
1 2 3 4 5


Sample Output

1
6


感觉吧,还是题目做的比较少的缘故。

题目大意:

两个数取亦或以后大于max(a,b),问ab的组合有几种。

思路:

首先看到这个题目,因为是亦或,所以一定要是不一样的。那么,假定我们sort以后从最小的开始枚举,每次枚举最小的这个数的二进制的前面的位数,如果前面的位数是0,那么看看有没有在该位置是1的,如果有,那就加上去。

思考一下为什么这么做可以:我们用bit[i]表示某个数字最高位所在的1的位置,例如3的话就是bit[2]++,并不需要bit[1]++(思考一下,因为如果你高位的亦或如果不满足了,那么你的低位满足了,还是相当于减少了,因此只需要bit[2]++即可)。

 

#include<bits stdc="" h="">

using namespace std;

int bit[233];
int a[100000 + 50];
int n;

void bi(int x){
int l = 31;
while (l >= 0){
if (x & (1 << l)){
bit[l]++;
return ;
}
l--;
}
}

void init(){
memset(bit, 0, sizeof(bit));
memset(a, 0, sizeof(a));
scanf("%d", &n);
for (int i = 0; i < n; i++){
scanf("%d", a + i);
bi(a[i]);
}
//for (int i = 0; i <= 3; i++) printf("%d\n", bit[i]);
}

void solve(){
int cnt = 0;
for (int i = 0; i < n; i++){
int tmp = a[i];
int l = 31;
while (l >= 0){
if (tmp & (1 << l)) break;
l--;
}
while (l >= 0){
if (!(tmp & (1 << l))) cnt += bit[l];
l--;
}
}
printf("%d\n", cnt);
}

int main(){
int t;
scanf("%d", &t);
while (t--){
init();
solve();
}
return 0;
}
</bits>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: