您的位置:首页 > 其它

hdu 1312 Red and Black (dfs+bfs)

2016-04-03 11:39 381 查看
Red and Black

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15731 Accepted Submission(s): 9730

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9

....#.

.....#

......

......

......

......

......

#@...#

.#..#.

11 9

.#.........

.#.#######.

.#.#.....#.

.#.#.###.#.

.#.#..@#.#.

.#.#####.#.

.#.......#.

.#########.

...........

11 6

..#..#..#..

..#..#..#..

..#..#..###

..#..#..#@.

..#..#..#..

..#..#..#..

7 7

..#.#..

..#.#..

###.###

...@...

###.###

..#.#..

..#.#..

0 0

Sample Output

45

59

6

13

dfs

#include<stdio.h>
#include<string.h>
#include <string>
#include <queue>
#include <iostream>
using namespace std;
char map[103][103];
int dir[4][2]={1,0,0,1,-1,0,0,-1};
int m,n,cnt;
/*void dfs(int x,int y)
{
if (map[x][y]=='#')
return ;
map[x][y]='#';
cnt++;
for (int i=0;i<4;i++)
{
int ax=x+dir[i][0];
int ay=y+dir[i][1];
if (ax<m&&ax>=0&&ay<n&ay>=0)
dfs(ax,ay);
}
}*/
void dfs(int x,int y)
{
int i;
for (i=0;i<4;i++)
{
int ax=x+dir[i][0];
int ay=y+dir[i][1];
if (ax<m&&ax>=0&&ay<n&&ay>=0&&map[ax][ay]!='#')
{
cnt++;
map[ax][ay]='#';
dfs(ax,ay);
}
}
}
int main()
{
int i,j,px,py;
while (~scanf("%d%d",&n,&m),m+n)
{
getchar();
for (i=0;i<m;i++)
{
for (j=0;j<n;j++)
{
scanf("%c",&map[i][j]);
if (map[i][j]=='@')
{
px=i;
py=j;
}
}
getchar();
}
cnt=1;
map[px][py]='#';
dfs(px,py);
printf("%d\n",cnt);
}
return 0;
}
bfs

#include<stdio.h>
#include<string.h>
#include <string>
#include <queue>
#include <iostream>
using namespace std;
char map[103][103];
int dir[4][2]={1,0,0,1,-1,0,0,-1};
int m,n,cnt;
typedef struct node{
int x,y;
}node;
void bfs(int x,int y)
{
queue<node> Q;
node start,t1,t2;
start.x=x,start.y=y;
Q.push(start);
while (!Q.empty())
{
t1=Q.front();
Q.pop();
for (int i=0;i<4;i++)
{
int ax=t1.x+dir[i][0];
int ay=t1.y+dir[i][1];
if (ax<m&&ax>=0&&ay<n&&ay>=0&&map[ax][ay]!='#')
{
t2.x=ax,t2.y=ay;
map[ax][ay]='#';
cnt++;
Q.push(t2);
}
}
}
}
int main()
{
int i,j,px,py;
node s;
while (~scanf("%d%d",&n,&m),m+n)
{
getchar();
for (i=0;i<m;i++)
{
for (j=0;j<n;j++)
{
scanf("%c",&map[i][j]);
if (map[i][j]=='@')
{
px=i;
py=j;
map[px][py]='#';
}
}
getchar();
}
cnt=1;
bfs(px,py);
printf("%d\n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: