您的位置:首页 > 其它

hdoj Lining Up 1432 (数学)直线过最多点问题

2016-04-02 17:21 381 查看


Lining Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1251    Accepted Submission(s): 356


Problem Description

``How am I ever going to solve this problem?" said the pilot. 

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points
were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number? 

Your program has to be efficient! 

 

Input

The input consists of multiple test cases, and each case begins with a single positive integer on a line by itself indicating the number of points, followed by N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended
by a new-line character. No pair will occur twice in one test case. 

 

Output

For each test case, the output consists of one integer representing the largest number of points that all lie on one line, one line per case.

 

Sample Input

5
1 1
2 2
3 3
9 10
10 11

 

Sample Output

3//题意:给你n个点的坐标,现在问一条直线能穿过最多的点的个数。//思路:直线方程:y=k*x+b;因为两点确定一条直线,所以用两层for可以将所有的直线找出来,用一个结构体存放直线的k,b,因为知道k,b就可以唯一确定一条直线。所以找k,b相同的直线的最多条数就行了,当然得把重复的去掉。运用去重公式即可(具体在代码中)。
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<iostream>
#define INF 0x3f3f3f3f
#define ull unsigned long long
#define ll long long
#define IN __int64
#define N 710
#define M 100000000
using namespace std;
struct zz
{
int x;
int y;
}p
;
int cmp(zz a,zz b)
{
if(a.x==b.x)
return a.y<b.y;
return a.x<b.x;
}
struct ss
{
double k;
double b;
}pp[N*N];
bool cmpp(ss a,ss b)
{
if(a.k==b.k)
return a.b<b.b;
return a.k<b.k;
}
int main()
{
int n,i,j,k;
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<n;i++)
scanf("%d%d",&p[i].x,&p[i].y);
sort(p,p+n,cmp);
int kk=0;
int km=0;
for(i=0;i<n-1;i++)
{
for(j=i+1;j<n;j++)
{
int x=p[j].x-p[i].x;
int y=p[j].y-p[i].y;
pp[kk].k=y*1.0/x;
pp[kk].b=p[i].y-pp[kk].k*p[i].x;
kk++;
}
}
sort(pp,pp+kk,cmpp);
int m=1,mm=1;
ss f=pp[0];
for(i=1;i<kk;i++)
{
if(fabs(pp[i].k-f.k)<1e-6&&fabs(f.b-pp[i].b)<1e-6)
{
m++;
mm=max(mm,m);
}
else
{
f=pp[i];
m=1;
}
}
if(n==1)
printf("1\n");
else if(n==2)
printf("2\n");
else
{
if(mm==3)
printf("%d\n",mm);
else
{
mm*=2;
for(int i=1;i<=n;i++) //去重公式
{
if(i*(i+1)==mm)
{
printf("%d\n",i+1);
break;
}
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: