您的位置:首页 > 其它

ACM-水题 Ace of Aces

2016-04-02 16:53 267 查看
题目

 

There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops.
The elected guy will be honored with the title of "Ace of Aces".

After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated
will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.

Please write program to help TSAB determine who will be the "Ace of Aces".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1
<= Ai <= 1000).

Output

For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.

Sample Input

3
5
2 2 2 1 1
5
1 1 2 2 3
1
998


Sample Output

2
Nobody
998


 
代码:
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
int main()
{
int a[1001],b,c,t,n,p,q;
cin>>t;
while(t--)
{
cin>>n;
memset(a,0,sizeof(a));
p=q=0;
while(n--)
{
cin>>b;
a[b]++;
if(a[b]>=p)
{
q=p;
p=a[b];
c=b;
}
}
if (q==p)

cout<<"Nobody"<<endl;
else cout<<c<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: