您的位置:首页 > 其它

poj 3009 curling

2016-04-02 16:17 369 查看
刚开始的时候走错了路 试图用BFS解题 浪费了不少时间
///本题虽然是要找 “最短路”,但是BFS几乎不可能,因为每“走一步”,场地的状态就要

///改变一次;而如果该步不满足要求,又要求把场地的状态还原到前一步,这只有DFS

///能做到。

///步数超过10则视为失败”的条件,这是用来剪枝的

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game
is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed
until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.



Fig. 1: Example of board (S: start, G: goal)
The movement of the stone obeys the following rules:

At the beginning, the stone stands still at the start square.
The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
Once thrown, the stone keeps moving to the same direction until one of the following occurs:

The stone hits a block (Fig. 2(b), (c)).

The stone stops at the square next to the block it hit.
The block disappears.

The stone gets out of the board.

The game ends in failure.

The stone reaches the goal square.

The stone stops there and the game ends in success.

You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.



Fig. 2: Stone movements
Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).



Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board

First row of the board

...

h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position
The dataset for Fig. D-1 is as follows:

6 6

1 0 0 2 1 0

1 1 0 0 0 0

0 0 0 0 0 3

0 0 0 0 0 0

1 0 0 0 0 1

0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input
2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output
1
4
-1
4
10
-1

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int map[50][50];
const int dx[4] = {0,0,-1,1};
const int dy[4] = {1,-1,0,0};
int w,h;
const int Max = 65535;
int min_step = Max;
void dfs(int x,int y, int step)
{
if(map[x][y] == 3)
{
min_step = min(min_step, step);
return;
}
if(step>=min_step || step >10)
return;
int x_now,y_now;
int x_new,y_new;
for(int i=0; i<4; i++)
{
x_new = x + dx[i];
y_new = y + dy[i];
x_now = x;
y_now = y;
while(x_new>=0 && x_new<h && y_new>=0 && y_new<w && map[x_new][y_new]!=1)
{
x_now += dx[i];
y_now += dy[i];
if(map[x_now][y_now] == 3)
{
min_step = min(min_step, step);
return;
}
x_new += dx[i];
y_new += dy[i];
if(x_new<0 || x_new>=h || y_new<0 || y_new>=w)
break;
if(map[x_new][y_new] == 1)
{
map[x_new][y_new] = 0;
dfs(x_now, y_now, step+1);
map[x_new][y_new] = 1;
}
}
}

}
int main()
{
int x = 0;
int y = 0;
while(cin >> w >> h && w && h)
{
for(int i=0; i<h; i++)
{
for(int j=0; j<w; j++)
{
cin >> map[i][j];
if(map[i][j] == 2)
{
x = i;
y = j;
}
}
}
dfs(x, y, 1);
if(min_step == Max)
cout << "-1\n";
else
cout << min_step << endl;
min_step = Max;

}
return 0;
}
(ps: 参考自某大神的代码)
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: