您的位置:首页 > 其它

hdu1018——Big Number(大数阶乘,斯特林公式)

2016-04-02 10:06 417 查看
Problem Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of
the number.

 

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

 

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

 

Sample Input

2
10
20

 

Sample Output

7
19

n的位数=log10(n)+1,m=n!,=log10^1+log10^2+...+log10^n

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
int n,m,i,ans;
double t;
scanf("%d",&n);
while(n--)
{
scanf("%d",&m);
t=0;
for(i=2;i<=m;++i)
t+=log10(i*1.0);
ans=int(t)+1;
cout<<ans<<endl;
}
return 0;
}

Stirling公式:n!与√(2πn) * n^n * e^(-n)的值十分接近
故log10(n!) = log(n!) / log(10) = ( n*log(n) - n + 0.5*log(2*π*n))/log(n);

#include <stdio.h>
#include <math.h>

const double PI = acos(-1.0);
const double ln_10 = log(10.0);

double reback(int N)
{
return ceil((N*log(double(N))-N+0.5*log(2.0*N*PI))/ln_10);
}

int main()
{
int cas,n;
scanf("%d",&cas);
while(cas--)
{
scanf("%d",&n);
if(n<=1)printf("1\n");
else printf("%.0lf\n",reback(n));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: