您的位置:首页 > 其它

UVA 839(DFS)

2016-04-01 23:23 344 查看
Before being an ubiquous communications gadget, a mobile

was just a structure made of strings and wires suspending

colourfull things. This kind of mobile is usually found hanging

over cradles of small babies.

The figure illustrates a simple mobile. It is just a wire,

suspended by a string, with an object on each side. It can

also be seen as a kind of lever with the fulcrum on the point where the string ties the wire. From the

lever principle we know that to balance a simple mobile the product of the weight of the objects by

their distance to the fulcrum must be equal. That is Wl × Dl = Wr × Dr where Dl

is the left distance,

Dr is the right distance, Wl

is the left weight and Wr is the right weight.

In a more complex mobile the object may be replaced by a sub-mobile, as shown in the next figure.

In this case it is not so straightforward to check if the mobile is balanced so we need you to write a

program that, given a description of a mobile as input, checks whether the mobile is in equilibrium or

not.

Input

The input begins with a single positive integer on a line by itself indicating the number

of the cases following, each of them as described below. This line is followed by a blank

line, and there is also a blank line between two consecutive inputs.

The input is composed of several lines, each containing 4 integers separated by a single space.

The 4 integers represent the distances of each object to the fulcrum and their weights, in the format:

Wl Dl Wr Dr

If Wl or Wr is zero then there is a sub-mobile hanging from that end and the following lines define

the the sub-mobile. In this case we compute the weight of the sub-mobile as the sum of weights of

all its objects, disregarding the weight of the wires and strings. If both Wl and Wr are zero then the

following lines define two sub-mobiles: first the left then the right one.

Output

For each test case, the output must follow the description below. The outputs of two

consecutive cases will be separated by a blank line.

Write ‘YES’ if the mobile is in equilibrium, write ‘NO’ otherwise.

Sample Input

1

0 2 0 4

0 3 0 1

1 1 1 1

2 4 4 2

1 6 3 2

Sample Output

YES

这道题的题意是给了天平两端物体的重量及力矩,判断天平是否平衡。这道题的天平下面可能有子天平,如果某个天平的某一端下面有子天平,则这一端的w输入时为0,这一端的重量是此端下面所有物体的重量和。这道题的输入时是递归输入的,紫书上的代码十分精简,具体操作过程会在代码中以注释方式写出。

#include <iostream>
#include <cstdio>

using namespace std;

bool solve(int &w)
{
int w1, d1, w2, d2;
bool b1 = true, b2 = true;
cin >> w1 >> d1 >> w2 >> d2;//由于是递归输入,所以每递归一次输入一组,处理一组
if (!w1) b1 = solve (w1);//将w1、w2变成了子天平的重量和。DFS思想。
if (!w2) b2 = solve (w2);
w = w1 + w2;
return b1 && b2 && (w1 * d1 == w2 * d2);
}

int main()
{
#ifndef ONLINE_JUDGE
freopen ("in.txt", "r", stdin);
#endif // ONLINE_JUDGE
int t, w;
cin >> t;
while (t--) {
if (solve (w)) cout << "YES\n";
else cout << "NO\n";
if (t) cout << "\n";
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: