您的位置:首页 > 其它

[UVa 1225]:Digit Counting

2016-04-01 13:48 399 查看
Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 to N (1 < N < 10000) . After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, with N = 13 , the sequence is:

12345678910111213

In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program.

Input

The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.

For each test case, there is one single line containing the number N .

Output

For each test case, write sequentially in one line the number of digit 0, 1,…9 separated by a space.

Sample Input

2

3

13

Sample Output

0 1 1 1 0 0 0 0 0 0

1 6 2 2 1 1 1 1 1 1

简单的题目:

意思就是说:输入一个数代表测试的组数,再分别输入每个组别代表的数,计算从1开始到所给的数的0-9的个数分别是多少(上面例子也很好的表达出了题意)

#include<stdio.h>
#include<string.h>
#define N 10

int main()
{
int n, num
;
scanf("%d", &n);
int a, i;
while(n--){
scanf("%d", &a);
memset(num, 0, sizeof(num)); // 每个数个数重新设为0
for(i=1; i<=a; i++){
int j = i;
while(j){ // 用于分离出某个数的各位数
num[j%10]++;
j /= 10;
}
}
int first = 0;
for(i=0; i<=9; i++){
if(first++){
printf(" ");
}
printf("%d", num[i]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: