您的位置:首页 > 运维架构

NOIP 2015 d2t1【poj 3258】 River Hopscotch 二分

2016-04-01 09:14 393 查看
River Hopscotch

Time Limit: 2000MS Memory Limit: 65536K

Total Submissions: 10628 Accepted: 4558

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance before he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M

Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2

2

14

11

21

17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

Source

USACO 2006 December Silver

题目链接http://poj.org/problem?id=3258

思路:简单二分,注意河岸的判断,详见代码

代码

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int a[50005];
int n,m,k;
bool C(int x)
{
int ret=0;
int i=0,j;
while(i<=m)
{
j=i+1;
//   if(i==5) cout<<a[j]-a[i]<<endl;
while(a[j]-a[i]<x&&j<=m+1)
{

j++,ret++;
if(ret>k) return 0;
}
i=j;
}
if(i<m+1) ret++;
if(ret>k) return 0;
return 1;
}
int cmp(int x,int y)
{
return x<y;
}
int main()
{
a[0]=0;
scanf("%d%d%d",&n,&m,&k);
for(int i=1;i<=m;i++)
scanf("%d",&a[i]);
a[m+1]=n;
sort(a+1,a+1+m,cmp);
int ans;
int lx=1;
int rx=n;

while(lx<=rx)
{
int mid=(lx+rx)/2;
if(C(mid))
{
ans=mid;
lx=mid+1;
}
else rx=mid-1;
}

printf("%d\n",ans);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: