您的位置:首页 > 其它

【poj 3273】 Monthly Expense 二分

2016-04-01 08:35 621 查看
Monthly Expense

Time Limit: 2000MS Memory Limit: 65536K

Total Submissions: 21071 Accepted: 8251

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M

Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5

100

400

300

100

500

101

400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题目链接http://poj.org/problem?id=3273

题意:给N个数,划分为M个块(不得打乱数顺序)。找到一个最好的划分方式,使得块中的最大值 最小。

思路:简单二分,o(n) 判断

代码

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int n,m;
int a[100005];
int h,l;
bool C(int x)
{
int ret=0;
int g=1;
for(int i=1;i<=n;i++)
{
if(ret+a[i]<=x)
ret+=a[i];
else
{
//  cout<<"        "<<g<<"    "<<i<<endl;
if(a[i]>x) return 0;
ret=a[i];
g++;

if(g>m) return 0;
}
}

if(g<=m) return true;
return false;
}
int main()
{
l=10005;
h=0;
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
h+=a[i];
l=min(a[i],l);
}
int lx=l;
int rx=h;
int ans=h;

while(lx<=rx)
{
//cout<<lx<<"     "<<rx<<endl;
int mid=(lx+rx)/2;
if(C(mid))
{
//cout<<"       "<<mid<<endl;
ans=min(ans,mid);
rx=mid-1;
}
else lx=mid+1;
}
printf("%d\n",ans);

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: