您的位置:首页 > 其它

POJ3122

2016-03-31 00:24 381 查看
Description

My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:

One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.

One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10 −3.

Sample Input

3

3 3

4 3 3

1 24

5

10 5

1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327

3.1416

50.2655

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>

using namespace std;
const double pi = 3.1415926535897932;//一定要开的很大很大
const int maxn = 10000 + 5;
int n, f;
double pie[maxn], sum;

bool can(double mid)
{
int fs = 0;
for (int i = 0; i < n; i++) {
fs += (int) (pie[i] / mid);
}
//cout << fs << " a " << f << endl;
return fs >= f;
}

double solve()
{
double mid, s;

double lb = 0, ub = sum / f;//最大值是所有的平分给f个人
//cout << ub << endl;
while (ub - lb > 1e-6) {
//cout <<lb << " " << ub << endl;
double mid = (lb + ub) / 2;
if (can (mid)) lb = mid;
else ub = mid;
}
return pi * lb;
}

int main()
{
#ifndef ONLINE_JUDGE
freopen ("in.txt", "r", stdin);
#endif // ONLINE_JUDGE
int t, r;
cin >> t;
while (t--) {
sum = 0;
memset (pie, 0, sizeof(r));
cin >> n >> f;
f++;//算上自己
for (int i = 0; i < n; i++) {
cin >> r;
pie[i] = r * r;//因为最后要算最小面积,所以一开始就用R*R算
sum += pie[i];
}

printf ("%.4f\n", solve());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: