您的位置:首页 > 其它

Day of Week

2016-03-30 23:38 405 查看
时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:6858

解决:2421

题目描述:

We now use the Gregorian style of dating in Russia. The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400.

For example, years 2004, 2180 and 2400 are leap. Years 2004, 2181 and 2300 are not leap.

Your task is to write a program which will compute the day of week corresponding to a given date in the nearest past or in the future using today’s agreement about dating.

输入:

There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). The month name is the corresponding English name starting from the capital letter.

输出:

Output a single line with the English name of the day of week corresponding to the date, starting from the capital letter. All other letters must be in lower case.

样例输入:
9 October 2001
14 October 2001


样例输出:
Tuesday
Sunday


提示:

Month and Week name in Input/Output:

January, February, March, April, May, June, July, August, September, October, November, December

Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday

题目大意:就是给出两个日期,问是星期几。。。
注意几个问题:
1.输入输出的转换,这个要熟练,比较水的。。熟练就好了
2.让其中一个已知的周几作为已知条件,从而求下面的。。
3.关键是求两个时间的差几天。。然后%7就好了。。。
求两个时间差几天这个有固定的格式。。见下面的代码就好了


#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#define ISYEAP(x) x%100!=0&&x%4==0||x%400==0?1:0
using namespace std;

int dayofmonth[13][2]={0,0,31,31,28,29,31,31,30,30,31,31,30,30,31,31,31,31,30,30,31,31,30,30,31,31};
struct Date{
int year;
int month;
int day;
//定义结构体函数,计算下一天的日期
void next_Day()
{
day++;
if(day>dayofmonth[month][ISYEAP(year)])
{
day=1;
month++;
if(month>12)
{
month=1;
year++;
}
}
}
};

//构造绝对值函数
int abs(int x)
{
return x>0?x:-x;
}
int buf[5005][13][31]={0};//用来保存当天和原点的日期 ,一开始放在main里面了,太大了,直接exit了,以后记住开大的数组放外面

int main()
{
int d,y,month_digit;//d,month_digit,y是要输出的天数
int y1,m1,d1;//作对比的天数
int cnt=1;
int xiangchaday;
struct Date tmp;
tmp.day=1;
tmp.month=1;
tmp.year=1000;
char m[15];
char week[7][20]={"Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"};
char month[12][20]={"January","February","March","April","May","June","July","August","September","October","November","December"};
while(tmp.year>=1000&&tmp.year<=3000)
{
buf[tmp.year][tmp.month][tmp.day]=cnt;
tmp.next_Day();
cnt++;
}
while(scanf("%d %s %d",&d,m,&y)!=EOF){
xiangchaday=0;
for(int i=0;i<12;i++)
{
if(strcmp(m,month[i])==0)
{
month_digit=i+1;
break;
}
}
if(buf[2001][10][9]<=buf[y][month_digit][d])
{
xiangchaday=buf[y][month_digit][d]-buf[2001][10][9];
int xingqi=xiangchaday%7;
printf("%s\n",week[(xingqi+2)%7]);
}
if(buf[2001][10][9]>buf[y][month_digit][d])
{
xiangchaday=buf[2001][10][9]-buf[y][month_digit][d];
int xingqi=xiangchaday%7;
printf("%s\n",week[(2+7-xingqi)%7]);
}

}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  九度oj