您的位置:首页 > 其它

poj1611 并查集

2016-03-30 21:18 337 查看
                                                                                                                                                The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 30559 Accepted: 14854
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student
is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the
number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1

题目意思:一共有n个学生(编号0 至 n-1),m个组,一个学生可以同时加入不同的组。现在有一种传染病,如果一个学生被感染,那么和他同组的学生都会被感染。现在已知0号学生被感染,问一共有多少个人被感染。

代码:
#include<iostream>
using namespace std;
int f[50000],n;
int find(int x)
{
    if(f[x]==x) return x;
    else
        return f[x]=find(f[x]);
}
int hebing(int u,int v)
{
    int i;
    int fx=find(u);
    int fy=find(v);
    if(fx!=fy)
    {
        for(i=0; i<n; i++)
        {
            if(f[i]==fy)
                f[i]=fx;
        }
    }
    return 0;
}
int main()
{
    int m,i,u,v,num;
    while(cin>>n>>m&&(n+m))
    {
        int sum=0;
        for(i=0; i<n; i++)
        {
            f[i]=i;
        }
        while(m--)
        {
            cin>>num;
            cin>>u;
            num--;
            while(num--)
            {
                cin>>v;
                hebing(u,v);
            }
        }
        for(i=0; i<n; i++)
        {
            if(f[i]==f[0])
            {
                sum++;
            }
        }
        cout<<sum<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: