您的位置:首页 > 其它

练习1-i

2016-03-30 15:27 211 查看

题目:Problem I

[align=left]Problem Description[/align]
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to
prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be
2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

 

[align=left]Input[/align]
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of
wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited
by one or more spaces.
 

[align=left]Output[/align]
The output should contain the minimum setup time in minutes, one per line.

 

[align=left]Sample Input[/align]

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

 

[align=left]Sample Output[/align]

2
1
3

题意:

       之前的原题。

思路:

        虽然是原题,之前做过,但是贴代码是居然不能通过,很是郁闷,之后从网上找了几组数据测试了一下,终于把错误找出来了!!原来是在写排序函数时少写了个条件,当木头的长度相同时还需要对其重量进行排序!!

感想:

       拖延症害死人;

代码:

# include <iostream>
# include <vector>
# include <algorithm>
# include <fstream>

using namespace std;

struct wooden
{
int l;
int w;
int nu;
bool operator < (const wooden &a) const
{
if(l ==  a.l)
return w <= a.w;
return l <= a.l;
}
};

int main()
{
//ifstream cin ("b.txt");
vector<wooden> wo;
wooden wwo;
int n;
cin >> n;
while(n--)
{
wo.clear();
int m;
cin >> m;
while (m--)
{
cin >> wwo.l >> wwo.w;
wwo.nu = 1;
wo.push_back(wwo);
}
sort (wo.begin(), wo.end());
//for (int i = 0; i < wo.size(); i++)
// cout << wo[i].l <<" " << wo[i].w<<endl;
int time = 0;
for (int i = 0; i < wo.size(); i++)
{
if (wo[i].nu == 0)
continue;
time ++;
int count = i;
for (int j = 0; j < wo.size(); j++)
{
if (wo[count].w <= wo[j].w && wo[j].nu != 0)
{
wo[j].nu = 0;
count = j;
}
}
}

cout << time <<endl;
}
return 0;
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: