您的位置:首页 > 其它

【poj 3176】 Cow Bowling 递推dp

2016-03-30 14:42 363 查看
Cow Bowling

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 16562 Accepted: 11036

Description

The cows don’t use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

7

3   8

8   1   0

2   7   4   4


4 5 2 6 5

Then the other cows traverse the triangle starting from its tip and moving “down” to one of the two diagonally adjacent cows until the “bottom” row is reached. The cow’s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5

7

3 8

8 1 0

2 7 4 4

4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample:

7

*

3   8

*

8   1   0

*

2   7   4   4

*


4 5 2 6 5

The highest score is achievable by traversing the cows as shown above.

Source

USACO 2005 December Bronze

题目链接http://poj.org/problem?id=3176

题目大意:数字三角形;

思路:递推

代码

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[351][351];
int n;
int dp[351][351];
int main()
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
for(int j=1;j<=i;j++)
scanf("%d",&a[i][j]);

dp[1][1]=a[1][1];
for(int i=2;i<=n;i++)
for(int j=1;j<=i;j++)
{
if(j!=i)
dp[i][j]=max(dp[i-1][j],dp[i-1][j-1]);
else dp[i][j]=dp[i-1][j-1];
dp[i][j]+=a[i][j];
}
int ans=0;
for(int i=1;i<=n;i++)
ans=max(ans,dp
[i]);
printf("%d\n",ans);

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: