您的位置:首页 > 其它

poj 2251 Dungeon Master(BFS)

2016-03-30 14:41 344 查看
Dungeon Master

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 24330Accepted: 9437
Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and
the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).

L is the number of levels making up the dungeon.

R and C are the number of rows and columns making up the plan of each level.

Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the
exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.

If it is not possible to escape, print the line

Trapped!

Sample Input
3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output
Escaped in 11 minute(s).
Trapped!


#include <cstdio>

#include <cstring>

#include <queue>

#include<iostream>

using namespace std;

const int dx[6] = {1, -1, 0, 0, 0, 0};

const int dy[6] = {0, 0, 1, -1, 0, 0};

const int dz[6] = {0, 0, 0, 0, 1, -1};

const int maxn = 35;

struct node

{

int x, y, z, step;

} tmp;

node S,T;

node now;

queue<node> q;

int n, m, t, x, y, z, i, j, k;

bool vis[maxn][maxn][maxn];

char mp[maxn][maxn][maxn];

int bfs()

{

while (!q.empty())

{

now = q.front();

q.pop();

for (i = 0; i < 6; ++i)

{

tmp.x = now.x + dx[i];

tmp.y = now.y + dy[i];

tmp.z = now.z + dz[i];

tmp.step = now.step + 1;

if(mp[tmp.z][tmp.y][tmp.x] == '#' ||vis[tmp.z][tmp.y][tmp.x] )

continue;

q.push(tmp);

vis[tmp.z][tmp.y][tmp.x] = true;

if(tmp.x == T.x && tmp.y == T.y && tmp.z == T.z)

return tmp.step;

}

}

return -1;

}

int main()

{

while (scanf("%d%d%d\n", &t, &n, &m)&& t && m && n)

{

memset(vis, 0, sizeof(vis));

memset(mp, '#', sizeof(mp));

while (!q.empty()) q.pop();

for (i = 1; i <= t; ++i)

{

for (j = 1; j <= n; ++j)

{

for (k = 1; k <= m; ++k)

{

mp[i][j][k] = getchar();

if (mp[i][j][k] == 'S')

{

vis[i][j][k] = true;

S.x = k;

S.y = j;

S.z = i;

S.step = 0;

q.push(S);

}

if (mp[i][j][k] == 'E')

{

T.x = k;

T.y = j;

T.z = i;

}

}

getchar();

}

getchar();

}

int ans = bfs();

if (ans<0) puts("Trapped!");

else

cout << "Escaped in " <<ans << " minute(s)." << endl;

}

return 0;

}

好久没有这种自己敲出代码的快感了!!! poj已过!!!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: