您的位置:首页 > 其它

hdu 1394 Minimum Inversion Number(这道题改日我要用线段树再做一次哟~)

2016-03-29 23:23 537 查看
[align=left]Problem Description[/align]
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, ..., an-1, an (where m = 0 - the initial seqence) a2, a3, ..., an, a1 (where m = 1) a3, a4, ..., an, a1, a2 (where m = 2) ... an, a1, a2, ..., an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.

[align=left]Input[/align]
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

[align=left]Output[/align]
For each case, output the minimum inversion number on a single line.

[align=left]Sample Input[/align]

10
1 3 6 9 0 8 5 7 4 2

[align=left]Sample Output[/align]

16

//有的大神是用线段树解的,原谅我怎么都无法看出线段树来。。。。_(:з」∠)_
//于是采用暴力解,然而。。超时了 (╯‵□′)╯︵┴─┴
//于是借鉴别人的代码~~~ (●'◡'●)
//思路:每次把末尾的数掉到序列前面时,减少的逆序对数为n-1-a[i] ,
//增加的逆序对数为a[i] ,这样就可在所有的序列中找出含有逆序对最少的了!(ps:给跪了,这是性质吗。。。

#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
int n,ans,k;
int data[5005];
while(cin>>n)
{
ans=0;
for(int i=0;i<n;i++)
scanf("%d",&data[i]);
for(int i=0;i<n;i++)
{
for(int j=i;j<n;j++)
{
if(data[i]>data[j])
ans++;
}
}
k=ans;
for(int i=n-1;i>=0;i--)
{
k-=n-1-data[i];
k+=data[i];
if(ans>k)
ans=k;
}
cout<<ans<<endl;
}
return 0;
}


//再贴上我的狗血超时代码。。。

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

int find(int a[],int n)
{
int ans=0;
for(int i=0;i<n;i++)
{
for(int j=i+1;j<n;j++)
{
if(a[i]>a[j])
ans++;
}
}
return ans;
}

int main()
{
int n;
int data[5005],num[5005];
while(scanf("%d",&n)!=-1)
{
for(int i=0;i<n;i++)
scanf("%d",&data[i]);
for(int i=0;i<n;i++)
{
num[i]=find(data,n);
int tmp=data[n-1];
for(int j=n-1;j>=1;j--)
{
data[j]=data[j-1];
}
data[0]=tmp;
}
sort(num,num+n);
cout<<num[0]<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: