您的位置:首页 > 其它

2016SDAU课程练习一1008 Problem I

2016-03-29 22:18 288 查看
Problem B
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 147   Accepted Submission(s) : 42
[align=left]Problem Description[/align]
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to
prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

 

[align=left]Input[/align]
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden
sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one
or more spaces.
 

[align=left]Output[/align]
The output should contain the minimum setup time in minutes, one per line.

 

[align=left]Sample Input[/align]

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

 

[align=left]Sample Output[/align]

2
1
3

 大意就是切木头,第一个要1min准备时间,下一根如果l和w任意一个小于前一根就要重新准备,求最短时间。
典型的贪心,现在感觉这种传统的贪心题做起来越来越得心应手了,感觉贪心不难,难的是1、对数据排序2、处理数据,这道题本来想的是直接全排好序,然后直接判断 ,但是发现难以实现,因为两组数据无法同时排序,只能优先一组,于是选择排一组,算一组。
AC代码:
#include<iostream>

#include<cstdio>

#include<cstring>

#include<cmath>

#include<set>

#include<algorithm>

using namespace std;

struct wood{

    int l;

    int w;

}woods[5010];

int num[5050];

bool cmp(const wood &a,const wood &b){

    if(a.l!=b.l)

        return a.l>b.l;

    else

        return a.w>b.w;

}

int main(){

    int m,n,min;

    cin>>m;

    for(int i=0;i<m;i++){

        cin>>n;

        for(int k=0;k<n;k++){

            cin>>woods[k].l>>woods[k].w;

            num[k]=0;

        }

        sort(woods,woods+n,cmp);

        int sum=0;

  for(int k=0;k<n;k++){

   if(num[k])

                continue;

   min=woods[k].w;

   for(int j=k+1;j<n;j++)

   {

    if(min>=woods[j].w && !num[j])

    {

     min=woods[j].w;

     num[j]=1;

    }

   }

            sum++;

        }

        cout<<sum<<endl;

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: