您的位置:首页 > 其它

贪心1013

2016-03-29 20:09 302 查看
题目:

[align=left]Problem Description[/align]
Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.

All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how
many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost
sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.
 

[align=left]Input[/align]
Input is a sequence of lines, each containing two positive integers s and d.
 

[align=left]Output[/align]
For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.
 

[align=left]Sample Input[/align]

59 237
375 743
200000 849694
2500000 8000000

 

[align=left]Sample Output[/align]

116
28
300612
Deficit

 

代码:#include <iostream>  

using namespace std;  

  

int main()  

{  

    int s,d;  

    int res;  

    while(cin>>s>>d)  

    {  

        if(d>4*s)res=10*s-2*d;  

        else if(2*d>3*s)res=8*s-4*d;  

        else if(3*d>2*s)res=6*s-d*6;  

        else if(4*d>s)res=3*s-9*d;  

        else res=-1;  

        if(res<0)cout<<"Deficit"<<endl;  

        else cout<<res<<endl;  

    }  

    return 0;  
}  

题目比较难理解;题意 :有一个公司由于某个病毒使公司赢亏数据丢失,但该公司每月的 赢亏是一个定数,要么一个月赢利s,要么一月亏d。现在ACM只知道该公司每五个月有一个赢亏报表,而且每次报表赢利情况都为亏。在一年中这样的报表总共有8次(1到5,2到6,…,8到12),现在要编一个程序确定当赢s和亏d给出,并满足每张报表为亏的情况下,全年公司最高可赢利多少,若存在,则输出多多额,若不存在,输出"Deficit"。

贪心算法就是用局部最优代替整体最优解;五个一组;最后的亏空
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: