您的位置:首页 > 其它

HDOJ 1116-Play on Words【欧拉路径+欧拉回路+并查集】

2016-03-28 21:35 387 查看

Play on Words

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6898 Accepted Submission(s): 2335

[align=left]Problem Description[/align]
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm''
can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.

[align=left]Input[/align]
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000).
Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.

[align=left]Output[/align]
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each
exactly once. The words mentioned several times must be used that number of times.

If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.".

[align=left]Sample Input[/align]

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok


[align=left]Sample Output[/align]

The door cannot be opened.
Ordering is possible.
The door cannot be opened.


[align=left]Source[/align]
Central Europe 1999

解题思路:
就是将每个单词的首字母和尾字母,看成起点和终点的有向线段,我们要找出欧拉回路,或欧拉通路。欧拉回路就是每个点的出度和入度都是相等的,欧拉通路就是

只有两个端点出度入度不等且其中一个出度减去入度为1,另一个入度减出度为1。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define max 30
using namespace std;
char str[1000];
int in[max],out[max],p[max];
int set[max],vis[max];
int find(int x)
{
int cc=x;
int t;
while(x!=set[x])
{
x=set[x];
}
while(cc!=x)
{
t=set[cc];
set[cc]=x;
cc=t;
}
return x;
}
void join(int x,int y)
{
int xx=find(x);
int yy=find(y);
if(xx!=yy)
{
set[xx]=yy;
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
int i,j;
for(i=1;i<=26;i++)
{
set[i]=i;
vis[i]=0;
in[i]=out[i]=p[i]=0;
}
for(i=0;i<n;i++)
{
int x,y;
scanf("%s",str);
int ll=strlen(str);
x=str[0]-'a'+1;
y=str[ll-1]-'a'+1;
in[y]++;
out[x]++;
vis[x]=vis[y]=1;
join(x,y);
}
int ex=0;
for(i=1;i<=26;i++)
{
if(vis[i]&&set[i]==i)
{
ex++;
if(ex>1)
{
break;
}
}
}
if(ex>1)
{
printf("The door cannot be opened.\n");
continue;
}
int sum=0;
for(i=1;i<=26;i++)
{
if(vis[i]&&in[i]!=out[i])
{
p[sum++]=i;
}
}
if(sum==0)
{
printf("Ordering is possible.\n");
}
else if(sum==2&&(out[p[0]]-in[p[0]]==1&&in[p[1]]-out[p[1]]==1||in[p[0]]-out[p[0]]==1&&out[p[1]]-in[p[1]]==1))
{
printf("Ordering is possible.\n");
}
else
{
printf("The door cannot be opened.\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: