您的位置:首页 > 其它

HDU 2120 Ice_cream's world I

2016-03-28 19:13 495 查看
Description

ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition
the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between
A and B has a wall(A and B are distinct). Terminate by end of file.

Output

Output the maximum number of ACMers who will be awarded.

One answer one line.

Sample Input

8 10
0 1
1 2
1 3
2 4
34
0 5
5 6
6 7
36
4 7


Sample Output

3


原谅我其实看不懂题。

题意:问在一个图中,有几个环;(应该是这样)

小希同学那道题中判断环的思想,直接ans++;

AC代码:

#include <bits/stdc++.h>
using namespace std ;
int n , m , pre[2000],vis[2000],ans;
int find ( int x )
{
if(x!=pre[x])
return pre[x]=find(pre[x]);
return x ;
}
void mix(int x , int y )
{
int dx = find(x);
int dy = find(y);
if(dx!=dy)
{
pre[dy]=dx;
}
else ans++;
}
int main()
{
while(cin>>n>>m)
{
ans = 0 ;
for(int i = 0 ; i<n;i++)
{
vis[i]=0;
pre[i]=i;
}
for(int i= 0 ; i < m ; i++)
{
int a , b ;
cin>>a>>b;
mix(a,b);
}
cout<<ans<<endl;
}
return 0 ;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: